Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП

Публикация № 1038792

Разработка - Практика программирования

СКД Расшифровка Программная расшифровка Отчет ОбработкаРасшифровкиКомпановкиДанных

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

Подробно рассматривать все настройки схемы компоновки мы не будем, остановимся только на том, ради чего была сделана статья.

Имеется некий отчет, у него схема компоновки данных, наборы данных, ресурсы, Параметры, Настройки.

Основные настройки отчета:

1. Рассмотрим вкладку «Макеты» основной схемы компоновки данных.

В макете описано каждое поле, для того что бы можно было сделать расшифровку по ним.

Если поле не ссылочного типа:

- В параметре расшифровки указываем наименование параметра

- В параметрах макета в поле Выражение делаем выбор

- В Параметр расшифровки в поле Выражение указываем ссылку на документ, по которому будет производиться расшифровка.

Если поле ссылочного типа:

Все тоже самое, только в Параметр расшифровки добавляем 2 параметра:

- Один из низ это ссылка на элемент указанный в поле

- Второй это ссылка на документ, по которому будет производиться расшифровка

На этом со схемой компоновки данных закончили.

3. Формы в отчете я использовал БСПшные, только для расшифровки создал свою форму "ФормаРасшифровки" с типом «Форма Отчета»

4. Открываем основную форму отчета БСП, для элемента формы «ОтчетТабличныйДокумент»  ищем событие «ОбработкаРасшифровки» и переходим в нее.

В открывшейся процедуре вызываем процедуру обработки в переопределяемом модуле.

ОтчетыКлиентПереопределяемый.ОбработкаРасшифровки(ЭтотОбъект, Элемент, Расшифровка, СтандартнаяОбработка);

5. Проверяем имя отчета, при необходимости подсистему на существование, определяем модуль дальнейшей обработки и вызываем из него следующую процедуру.

Процедура ОбработкаРасшифровки(ФормаОтчета, Элемент, Расшифровка, СтандартнаяОбработка) Экспорт
	
	Если ФормаОтчета.НастройкиОтчета.ПолноеИмя = "Отчет.ДвижениеМаркированногоТовара" Тогда
		
		Если ОбщегоНазначенияКлиент.ПодсистемаСуществует(
			"ТакскомПодсистемы.ЭлектронныйДокументооборот.РеализацияМаркированнойПродукции") Тогда
			
			МодульРеализацияМаркированнойПродукцииКлиент = 
				ОбщегоНазначенияКлиент.ОбщийМодуль("РеализацияМаркированнойПродукцииКлиент");
		
			МодульРеализацияМаркированнойПродукцииКлиент.ОбработкаРасшифровкиОтчетаДвижениеМаркированногоТовара(
				ФормаОтчета, Расшифровка, СтандартнаяОбработка);
				
		КонецЕсли;
				
	КонецЕсли;		
	
КонецПроцедуры

6. Полный код вызываемой процедуры:

Процедура ОбработкаРасшифровкиОтчетаДвижениеМаркированногоТовара(ФормаОтчета, Расшифровка, СтандартнаяОбработка) Экспорт
	
	СтандартнаяОбработка = Ложь;
	
	ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(
		ФормаОтчета.ОтчетДанныеРасшифровки,
		Новый ИсточникДоступныхНастроекКомпоновкиДанных(ФормаОтчета.Отчет));
		
	ДополнительныеПараметры = Новый Структура;
	ДополнительныеПараметры.Вставить("Расшифровка", Расшифровка);
	ДополнительныеПараметры.Вставить("ОтчетДанныеРасшифровки", ФормаОтчета.ОтчетДанныеРасшифровки);
	ДополнительныеПараметры.Вставить("ФормаОтчета", ФормаОтчета);
		
	ОписаниеОповещения = Новый ОписаниеОповещения("ПоказатьВыборДействияЗавершение", ЭтотОбъект, ДополнительныеПараметры);
	
	ДоступныеДействия = Новый Массив;
	ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
	
	ДополнительныеПунктыМеню = Новый СписокЗначений;
	ДополнительныеПунктыМеню.Добавить("КодыМаркировки", НСтр("ru = 'Коды маркировки документа'"));
	
	ОбработкаРасшифровки.ПоказатьВыборДействия(ОписаниеОповещения, Расшифровка, ДоступныеДействия, ДополнительныеПунктыМеню); 
		
КонецПроцедуры

Разберем подробно код процедуры

Прежде всего отменяем стандартную обработку:

СтандартнаяОбработка = Ложь;

Создаем обработку расшифровки:

ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(
		ФормаОтчета.ОтчетДанныеРасшифровки,
		Новый ИсточникДоступныхНастроекКомпоновкиДанных(ФормаОтчета.Отчет));

 Создаем ОписаниеОповещения с параметрами, для алгоритма после выбора действия пользователем:

ДополнительныеПараметры = Новый Структура;
ДополнительныеПараметры.Вставить("Расшифровка", Расшифровка);
ДополнительныеПараметры.Вставить("ОтчетДанныеРасшифровки", ФормаОтчета.ОтчетДанныеРасшифровки);
ДополнительныеПараметры.Вставить("ФормаОтчета", ФормаОтчета);
		
ОписаниеОповещения = Новый ОписаниеОповещения("ПоказатьВыборДействияЗавершение", ЭтотОбъект, ДополнительныеПараметры);

Добавляем два действия, одно платформенное, другое создаем свое собственное "КодыМаркировки":

ДоступныеДействия = Новый Массив;
ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
	
ДополнительныеПунктыМеню = Новый СписокЗначений;
ДополнительныеПунктыМеню.Добавить("КодыМаркировки", НСтр("ru = 'Коды маркировки документа'"));

Вызываем меню выбора действий:

ОбработкаРасшифровки.ПоказатьВыборДействия(ОписаниеОповещения, Расшифровка, ДоступныеДействия, ДополнительныеПунктыМеню);

7. В обработке оповещения обрабатываем каждый пункт меню действий

- В первом случае просто открываем объект по ссылке

- Во втором вызываем процедуру, которая нам вернет выбранное поле.

И если Выбранное поле заполнено, тогда вызываем процедуру открывающую новую форму отчета.

Процедура ПоказатьВыборДействияЗавершение(ВыполненноеДействие, ПараметрВыполненногоДействия, ДополнительныеПараметры) Экспорт
		
	Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
		
		ПоказатьЗначение(Неопределено, ПараметрВыполненногоДействия);
		
	ИначеЕсли ВыполненноеДействие = "КодыМаркировки" Тогда
		
		ВыбранноеПоле = РеализацияМаркированнойПродукцииВызовСервера.ОбработкаРасшифровкиОтчетаДвижениеМаркированногоТовара(
			ДополнительныеПараметры.ОтчетДанныеРасшифровки, ДополнительныеПараметры.Расшифровка);
		
		Если ВыбранноеПоле = Неопределено Тогда
			Возврат
		КонецЕсли;
		
		ОткрытьОтчетРасшифровкуПоВыбранномуПолю(ДополнительныеПараметры.ФормаОтчета, ВыбранноеПоле);
		
	КонецЕсли;
	
КонецПроцедуры

Т.к. функция получения выбранного поля  находится в общем модуле с галочкой Вызов Сервера, то делаем там только инициализацию серверной функции

Функция ОбработкаРасшифровкиОтчетаДвижениеМаркированногоТовара(ОтчетДанныеРасшифровки, Расшифровка) Экспорт
	
	Возврат РеализацияМаркированнойПродукцииСервер.ПолеРасшифровкиОтчетаДвижениеМаркированногоТовара(
		ОтчетДанныеРасшифровки, Расшифровка)
	
КонецФункции

А уже в серверном общем модуле, описываем алгоритм получения выбранного поля Документ поступления.

Функция ПолеРасшифровкиОтчетаДвижениеМаркированногоТовара(ОтчетДанныеРасшифровки, Расшифровка) Экспорт
	
	ДанныеРасшифровки = ПолучитьИзВременногоХранилища(ОтчетДанныеРасшифровки);
	ПоляРасшифровки = ДанныеРасшифровки.Элементы.Получить(Расшифровка).ПолучитьПоля();
	
	НайденноеПоле = ПоляРасшифровки.Найти("ДокументПоступления");
	Если НайденноеПоле = Неопределено Тогда
		Возврат Неопределено;
	Иначе
		Возврат НайденноеПоле.Значение;
	КонецЕсли;
	
КонецФункции

 

8. Процедура инициализирует открытие формы отчета с передачей параметров.

Процедура ОткрытьОтчетРасшифровкуПоВыбранномуПолю(ФормаОтчета, ВыбранноеПоле)
	
	Отбор = Новый Структура;
	Отбор.Вставить("ДокументСсылка", ВыбранноеПоле);
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("Отбор", Отбор);
	ПараметрыФормы.Вставить("КлючНазначенияИспользования", "КодыМаркировки");
	
	ОткрытьФорму(
		"Отчет.ДвижениеМаркированногоТовара.Форма.ФормаРасшифровки", ПараметрыФормы, ФормаОтчета, ФормаОтчета.УникальныйИдентификатор);
		
КонецПроцедуры

9. В модуле открывшейся формы процедура ПриСозданииНаСервере:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Параметры.Свойство("АвтоТест") Тогда
		Возврат;
	КонецЕсли;
	
	СтандартнаяОбработка = Ложь;
	
	Запрос = "";
	Если Параметры.Отбор.Свойство("ДокументСсылка") Тогда        
		Запрос = СформироватьДинамическиЗапрос(Параметры.Отбор.ДокументСсылка);
	КонецЕсли;
	Если Запрос = "" Тогда
		Возврат;
	КонецЕсли;
	
	Схема = Отчеты.ДвижениеМаркированногоТовара.ПолучитьМакет("РасшифровкаКодыМаркировки");
	Схема.НаборыДанных[0].Запрос = Запрос;   
		
	//Из схемы возьмем настройки по умолчанию
	Настройки = Схема.НастройкиПоУмолчанию;
	Для Каждого СтрокаОтбора Из Параметры.Отбор Цикл
		
		Отбор = Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		Отбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(СтрокаОтбора.Ключ);
		Отбор.ПравоеЗначение = СтрокаОтбора.Значение;
		
	КонецЦикла;
	
	//Формируем макет, с помощью компоновщика макета
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	
	//Передаем в макет компоновки схему, настройки и данные расшифровки
	МакетКомпоновки = КомпоновщикМакета.Выполнить(Схема, Настройки);
		
	//Выполним компоновку с помощью процессора компоновки
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки);
	
	//Очищаем поле табличного документа
	Результат.Очистить();
	
	//Выводим результат в табличный документ
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(Результат);
	
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
		
	АвтоЗаголовок = Ложь;
	Заголовок = НСтр("ru = 'Коды операций (расшифровка)'");
	
КонецПроцедуры

Разберем ключевые строки процедуры:

- Проверяем параметры формы, и вызываем формирование динамического запроса по полученному параметру ссылки на документ.

Запрос = "";
Если Параметры.Отбор.Свойство("ДокументСсылка") Тогда        
	Запрос = СформироватьДинамическиЗапрос(Параметры.Отбор.ДокументСсылка);
КонецЕсли;
Если Запрос = "" Тогда
	Возврат;
КонецЕсли;

- Процедура формирования динамического запроса:

&НаСервере
Функция СформироватьДинамическиЗапрос(ДокументСсылка)
	
	ШаблонЗапроса = "ВЫБРАТЬ
	                |	КодыМаркировки.Ссылка КАК ДокументСсылка,
					|	КодыМаркировки.НомерСтроки КАК НомерСтроки,
	                |	КодыМаркировки.СерийныйНомер КАК СерийныйНомер
	                |ИЗ
	                |	Документ.%1.КодыМаркировки КАК КодыМаркировки";
	
	Запрос = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
		ШаблонЗапроса,
		ДокументСсылка.Метаданные().Имя);
		
	Возврат Запрос;	
	
КонецФункции

- Получаем макет скд и в первом наборе данных переопределяем запрос, на тот, что мы сформировали динамически выше.

Схема = Отчеты.ДвижениеМаркированногоТовара.ПолучитьМакет("РасшифровкаКодыМаркировки");
Схема.НаборыДанных[0].Запрос = Запрос;

Посмотрим на вкладку "Наборы данных" полученного макета расшифровки и видим что запрос в нем это лишь шаблон, т.к. мы заранее не знаем какой тип

документа будет расшифровываться. На вкладке "Настройки" вывод детальных записей, больше настроек у этой схемы нет.

- Применяем настройки и добавляем полученный в параметрах отбор

//Из схемы возьмем настройки по умолчанию
Настройки = Схема.НастройкиПоУмолчанию;
Для Каждого СтрокаОтбора Из Параметры.Отбор Цикл
		
	Отбор = Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	Отбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(СтрокаОтбора.Ключ);
	Отбор.ПравоеЗначение = СтрокаОтбора.Значение;
		
КонецЦикла;

- После располагается типовой код по программному формированию отчета,

куда мы передаем полученную схему, и сформированные настройки отчета.

 

P.S.

Статья, по формированию расшифровки, без использования БСП

Работа с расшифровкой отчета на СКД

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. artms 204 04.09.19 09:12 Сейчас в теме
Получение данных из документов, не зачет на экзамене, нужно было сделать регистр сведений, событием. Возможно здесь приводится отчет встроенный но "СформироватьДинамическиЗапрос" это мягко говоря не верно. Новый запрос, нужно сделать либо как отчет № 2 либо как второй набор данных передав параметр "КлючТекущегоВарианта", настройки. Параметры отчета нужно было передать через параметр "ПользовательскиеНастройки,Отбор", а не кодом "ПриСозданииНаСервере". Тогда ваш код не нужен почти весь, достаточно правильно настроить отчет № 2 или вариант. И сделать заполнение пользовательских настроек, полученных на основании расшифровки отчета № 2. Конечно, возможно автор пытался минимально изменить конфигурацию и это частично его оправдывает, но не оправдывает вторую часть публикации.
FirePyres; +1 Ответить
2. Viktor_Ermakov 175 04.09.19 23:47 Сейчас в теме
(1)Спасибо Вам за отзыв.
1. "Получение данных из документов, не зачет на экзамене, нужно было сделать регистр сведений, событием" - тут Вы правы, но это уже тема архитектуры, в рамках которой я был ограничен.
2. "СформироватьДинамическиЗапрос" - чем это плохо, поясните, ведь я заведомо не знаю тип документа по которому мне нужно получить расшифровку, поэтому формирую динамический запрос. Это кстати стандартная практика типовых решений в настоящее время.
3. "Новый запрос, нужно сделать либо как отчет № 2 либо как второй набор данных передав параметр "КлючТекущегоВарианта"" - это уже тонкости, вариации решения. Я против отчета №2, а вот второй набор можно сделать, но не вижу ничего плохого во второй схеме компоновки.
4. "Параметры отчета нужно было передать через параметр "ПользовательскиеНастройки,Отбор", а не кодом "ПриСозданииНаСервере"" - то что использовать нужно пользовательские настройки это да. Но что значит передать, я не понял.

Резюмирую: да, скорее всего представленный алгоритм можно улучшить, оптимизировать, я могу чего то не знать еще, все приходит с опытом.
Цель статьи была показать как в дорабатываемой конфигурации на БСП сделать отчет с расшифровкой, минимизируя изменения объектов на поддержке.
Designer1C; +1 Ответить
3. artms 204 05.09.19 13:21 Сейчас в теме
(2)
что значит передать,

2. "СформироватьДинамическиЗапрос" - это к получению данных из документов, в логике формирования запроса динамически нет никаких нарушений.
4.Делал открытие отчета СКД с заполнением параметров и отборами так :
// в общем модуле на сервере
Функция УстановитьПользовательскиеНастройкиОтчета(ТипОтчета,СтруктураПараметров)
	
	СтруктураНастроек = Новый Структура;
	ОтчетОбъект = Отчеты[ТипОтчета].Создать();
	
	ПользовательскиеНастройки = ОтчетОбъект.КомпоновщикНастроек.ПользовательскиеНастройки;
	Для Каждого ЭлПараметр  Из СтруктураПараметров Цикл
		Для Каждого ПараметрСКД Из ПользовательскиеНастройки.Элементы Цикл
			Если ТипЗнч(ПараметрСКД) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда  
				Если строка(ПараметрСКД.Параметр) = ЭлПараметр.Ключ Тогда 
					ПараметрСКД.Значение = ЭлПараметр.Значение;
					ПараметрСКД.Использование = Истина;
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	Возврат ПользовательскиеНастройки;
	
КонецФункции

&НаКлиенте
Процедура ОткрытьЦелевойПрием()

	СтрПараметры = Новый Структура;
	СтрПараметры.Вставить("ПриемнаяКампания", Объект.Ссылка);
		
	ПользовательскиеНастройки = УстановитьПользовательскиеНастройкиОтчета("ПК_ЦелевойПрием",СтрПараметры);
		
	Отбор = Новый Структура;
	Отбор.Вставить("Специальность");
	Отбор.Вставить("УсловияОбучения");
	ЗначенияКлючейРегистра = ЗначенияКлючейРегистра(ВыбраннаяСтрока,Отбор);
		
	ПараметрыФормы = Новый Структура("Отбор,ПользовательскиеНастройки, СформироватьПриОткрытии", Отбор,ПользовательскиеНастройки, Истина);
		
	ОткрытьФорму("Отчет.ПК_ЦелевойПрием.ФормаОбъекта", ПараметрыФормы); 
	
КонецПроцедуры
Показать


(УстановитьПользовательскиеНастройкиОтчета - сделана не рекурсивно, т.к. группы условий это не стандартные наборы параметров и их даже если есть устанавливать не нужно, так было принято)
6. Viktor_Ermakov 175 05.09.19 15:59 Сейчас в теме
(3) Спасибо за пояснения, учтем.
4. bmk74 136 05.09.19 15:12 Сейчас в теме
Хм ну и заморочки, так то уже все решено за вас
Ссылка на статью .
Добавить в расширение, единственное они в стандартном варианте почему то не сделали ключ варианта нельзя передать в открываемый отчет, но и это можно добавить...
5. Viktor_Ermakov 175 05.09.19 15:57 Сейчас в теме
(4) Во первых не совсем понял как Ваше решение покрывает задачу в данной статье?
У меня в расшифровке строится запрос к ТЧ документа, тип которого мне заранее не известен, поэтому запрос формируется динамически.

Во вторых о каком расширении может идти речь, если ты разрабатываешь свою конфигурацию на БСП.
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    7583    John_d    21       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    24859    ids79    47       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Обмен данными. Консистентность vs Многопоточность

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Интеграция

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    6596    m-rv    1       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    33949    ids79    36       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Обработчики событий при записи объектов. Зачем и что за чем?

Статья Программист Нет файла v8 Бесплатно (free) Математика и алгоритмы

Программисту, имеющему немного опыта на платформе 1С 8.3, бывает сложно разобраться: ПередЗаписью, ПриЗаписи, ПослеЗаписи, на сервере, на клиенте, в модуле формы, в модуле объекта.... Эта шпаргалка была создана в процессе обучения и реального опыта с целью разложить всё по полочкам, чтобы было четкое понимание в каком случае какой обработчик нужно использовать и в какой последовательности они запускаются при записи и проведении документов. Данная статья будет полезна в большей степени начинающим разработчикам. Но и опытным позволит освежить информацию, упорядочить её.

25.07.2019    24151    4    AlbinaAAA    25       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    9373    m-rv    2       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Как настроить правильную техподдержку (helpdesk, service desk на коленке)

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 УУ Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Бесплатно (free) Управление услугами и сервисом

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    11636    siddy    0       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    12510    m-rv    16       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Информирование пользователя. Работа с объектом «СообщениеПользователю»

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    28557    ids79    40       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Копирование числовых ячеек из 1С в Excel

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    15711    itriot11    21       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    52324    GeterX    95       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    26440    ids79    40       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    47645    stas_ganiev    73       

Вспомогательные инструкции в коде 1С

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    23804    tormozit    100       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Приемы работы с СКД: делаем за 5 минут то, на что у других уйдет час

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования Инструментарий разработчика

Сергей Наумов делится опытом нестандартного использования системы компоновки данных. Он рассказывает о построении сложных отчетов с помощью функций СКД, описывает преимущества использования компоновки в коде для значительного сокращения строк кода и времени на решение задач, а также рассказывает про отладку компоновки и возможности оптимизации ее работы.

03.09.2018    37692    SergeyN    26       

Из Excel в 1С запросом

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    16518    m-rv    5       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

[Шпаргалка] Свой заголовок отчету на СКД с параметрами, картинками (без программирования)

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Работа с интерфейсом

Если возникла необходимость в заголовок отчета вывести дополнительную информацию к примеру дату формирования отчета, тогда данная шпаргалка поможет вам быстро это сделать.

23.07.2018    35063    rpgshnik    58       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Повышаем эффективность разработки правил обмена

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    23261    olegtymko    47       

Как сделать запрос на изменение данных

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    24674    m-rv    21       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Строим графы средствами 1С (без GraphViz)

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    20563    slozhenikin_com    20       

Распределение расходов пропорционально продажам

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    14614    Rustig    9