Расширение для тех, кто не знает как убрать префиксы и лидирующие нули в печатных формах всех документов УТ 11.4

Публикация № 1291296

Разработка - Печать - Печатные формы документов

расширение

Те кто затрудняется при проблеме связанной с удалением префиксов и лидирующих нулей с печатных форм всех документов, вот Вам расширение.

Данное расширение убирает префиксы и лидирующие нули во всех печатных формах всех документов без исключения, а нужно это в первую очередь для красоты, для чего покупателям видеть внутренние обозначения программы, когда они созданы для идентификации документов например при обмене (синхронизации). 

В результате вместо такого номера УТ00000678 в печатной форме у Вас станет такой 678.

Данное расширение срабатывает автоматически, вызывать диалоговых окон не требуется.

Все манипуляции проводил в конфигурации 

Управление торговлей и взаимоотношениями с клиентами:
1С:Управление торговлей (11.4.12.81) + 1С:CRM (3.0.19.33)
Версия продукта (3.0.19.46)

Устанавливать расширение можно как через конфигуратор, так и в режиме 1С:Предприятие - НСИ и администрирование, печатные формы, отчеты и обработки - расширения.

При установке необходимо снять галочку "Безопасный режим"

 

Разумеется можно установить расширение на типовую конфигурацию, снимать с поддержки ее не нужно.

Скачать файлы

Наименование Файл Версия Размер
Расширение для тех, кто не знает как убрать префиксы и лидирующие нули в документах УТ 11.4:

.cfe 6,12Kb
09.09.20
29
.cfe 1 6,12Kb 29 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. malikov_pro 500 09.09.20 20:32 Сейчас в теме
Смысл обработки, если в типовых реализовано с учетом специфики конфигурации.

УНФ
Функция ПолучитьНомерНаПечатьСУчетомДатыДокумента(ДатаДокумента, НомерДокумента, Префикс) Экспорт
	
	Если ДатаДокумента < Дата('20110101') Тогда
		
		Возврат УправлениеНебольшойФирмойСервер.ПолучитьНомерНаПечать(НомерДокумента, Префикс);
		
	Иначе
		
		БезПрефиксаИнформационнойБазы = Константы.ПредставлениеНомераДокументаБезПрефиксаИнформационнойБазы.Получить();
		БезПрефиксаПользователя = Константы.ПредставлениеНомераДокументаБезПрефиксаПользователя.Получить();
		
		Возврат ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(НомерДокумента, БезПрефиксаИнформационнойБазы, БезПрефиксаПользователя);
		
	КонецЕсли;
	
КонецФункции

Показать


УТ 11
Если УдалитьТолькоЛидирующиеНулиИзНомераОбъекта Тогда
		НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.УдалитьЛидирующиеНулиИзНомераОбъекта(ДанныеДокумента.Номер);
	Иначе 
		// Кроме лидирующих нулей будут удалены также префикс организации и префикс информационной базы.
		НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ДанныеДокумента.Номер);
	КонецЕсли;
2. the1 600 09.09.20 22:56 Сейчас в теме
(1) Написано же - для тех, кто НЕ знает. Вы, очевидно, знаете)
4. VID1234 63 10.09.20 08:39 Сейчас в теме
(2) Здравствуйте. Это точно. Спасибо!
3. VID1234 63 10.09.20 08:39 Сейчас в теме
(1) Здравствуйте. Я например не знал, может еще кто-то не знает, расширение бесплатное, так что ничего страшного, если будет на сайте.
5. malikov_pro 500 10.09.20 11:07 Сейчас в теме
(3) Переиспользование типового функционала и использование расширения немного разные вещи.
Оставьте свое сообщение

См. также

Заполнение контрагентов по ИНН. Назад в будущее

Адаптация типовых решений v8 Россия Бесплатно (free)

Что делать, если Ваш клиент не смог выйти из каменного века и вместо вменяемой часто модифицируемой под нужды современного мира конфигурации, у него неподъемный мамонт, который пережил несколько ледниковых эпох, такой неуклюжий, умирающий, но близкий к бизнесу и родной сердцу? Проблемы начинаются тогда, когда у этого мамонта отваливаются зубья, или его обладатель поглядывает на современные конфигурации и начинает желать новшеств в виде весоподъемности и скорости самолета. Да вообще и чтобы все, что должно работать, работало в конце концов, как, например, внезапно умерший сервис 1С:Контрагент! А у некоторых мамонтов, он, совершенно точно, провонял и усох. И вот как положить этот артефакт в микроволновку времени и вернуть к работоспособному состоянию.

12.05.2020    2160    0    G.Shatrov    6    

Сканирование, сохранение и печать документов

Сканер штрих-кода Печатные формы документов v8 1cv8.cf Россия Бесплатно (free)

Сканирование с использованием WIA, хранение в справочнике "Хранилище дополнительной информации" и печать из документов и справочников.

01.02.2011    30811    0    anig99    16    

Ручная запись версии объекта (для снеговика)

Печатные формы документов Универсальные функции Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Бесплатно (free)

Печатная форма для УПП 1.3.6.1 и алгоритм создания для любых других конфигураций с существующей системой версионирования.

07.11.2010    17563    0    anig99    1    

Структура подчинённости

Универсальные функции Печатные формы документов v8 1cv8.cf Бесплатно (free)

Немного переписанная типовая обработка "Структура подчинённости". Отличается от типовой тем, что видит все подчинённые документы, а не только упомянутые в критерии отбора.

04.02.2009    28211    0    e.kogan    26