Проверка контрагента по номеру телефона перед записью

Программирование - Практика программирования

4
Проверка контрагента перед записью на номер телефона, чтобы не было дублей.

Код писался на УНФ 1.6.12.4. Но подойдет и для любой другой. Чуток подправить под конфу, если надо и все.

1) Создать серверный общий модуль.

2) Создать подписку на событие объекта справочника. Указать в ней следующую процедуру:

Ну и весь код общего модуля. При желании можно добавить еще какую-нибудь проверку.

#Область ПодпискиНаСобытия

Процедура aspect_ПередЗаписьюСправочникаПередЗаписью(Источник, Отказ) Экспорт
	
	Если ТипЗнч(Источник) = Тип("СправочникОбъект.Контрагенты") Тогда
		Если НЕ ЗначениеЗаполнено(Источник.Ссылка) Тогда
			Если ЗначениеЗаполнено(Источник.НомерТелефона) Тогда
				// необходимо произвести поиск по этому номеру телефона, предварительно обработав его
				// т.к. номер может быть введен по-разному
				ТаблицаСообщений = Новый ТаблицаЗначений;
				ТаблицаСообщений.Колонки.Добавить("ТекстСообщения", Новый ОписаниеТипов("Строка"));
				ТаблицаСообщений.Колонки.Добавить("Контрагент"    , Новый ОписаниеТипов("СправочникСсылка.Контрагенты"));
				НомерТелефонаДляПроверки = ПреобразоватьНомерТелефонаДляПроверки(Источник.НомерТелефона);
				Запрос = Новый Запрос;
				Запрос.Текст =
				"ВЫБРАТЬ
				|	Контрагенты.Ссылка КАК Ссылка,
				|	Контрагенты.НомерТелефона КАК НомерТелефона
				|ИЗ
				|	Справочник.Контрагенты КАК Контрагенты
				|ГДЕ
				|	НЕ Контрагенты.ЭтоГруппа
				|	И НЕ Контрагенты.НомерТелефона = &ПустойНомерТелефона";
				Запрос.УстановитьПараметр("ПустойНомерТелефона", "");
				РезультатЗапроса = Запрос.Выполнить();
				Если НЕ РезультатЗапроса.Пустой() Тогда
					ВыборкаЗапроса = РезультатЗапроса.Выбрать();
					Пока ВыборкаЗапроса.Следующий() Цикл
						ТекущийНомерТелефона = ПреобразоватьНомерТелефонаДляПроверки(ВыборкаЗапроса.НомерТелефона);
						Для i=1 По СтрЧислоСтрок(ТекущийНомерТелефона) Цикл
							Для m=1 По СтрЧислоСтрок(НомерТелефонаДляПроверки) Цикл
								Если СтрПолучитьСтроку(ТекущийНомерТелефона, i) = СтрПолучитьСтроку(НомерТелефонаДляПроверки, m) Тогда
									ТекстСообщения = "Номер телефона: '" + СтрПолучитьСтроку(НомерТелефонаДляПроверки, m) + "' уже привязан к контрагенту: '" + Строка(ВыборкаЗапроса.Ссылка) + "'";
									НоваяСтрока = ТаблицаСообщений.Добавить();
									НоваяСтрока.ТекстСообщения = ТекстСообщения;
									НоваяСтрока.Контрагент     = ВыборкаЗапроса.Ссылка;
									Отказ = Истина;
								КонецЕсли;
							КонецЦикла;
						КонецЦикла;
					КонецЦикла;
				КонецЕсли;
				
				Если ТаблицаСообщений.Количество() > 0 Тогда
					ТекстСообщения = "Открыть контрагента можно двойным нажатием ЛКМ";
					ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
					Для каждого СтрокаСообщения Из ТаблицаСообщений Цикл
						ОбщегоНазначенияКлиентСервер.СообщитьПользователю(СтрокаСообщения.ТекстСообщения, СтрокаСообщения.Контрагент, , , );
					КонецЦикла;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

Функция ПреобразоватьНомерТелефонаДляПроверки(НомерТелефона)
	
	НомерТелефонаДляПроверки = НомерТелефона;
	
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, " ", "");
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, "+", "");
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, "(", "");
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, ")", "");
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, "-", "");
	НомерТелефонаДляПроверки = СтрЗаменить(НомерТелефонаДляПроверки, ",", Символы.ПС);
	
	Возврат НомерТелефонаДляПроверки;
	
КонецФункции

 

4

См. также

Комментарии
Избранное Подписка Сортировка: Древо
2. veyron21 120 16.05.18 17:46 Сейчас в теме
А чем связка ИНН/КПП не устраивает? Или в вашей базе много физиков?
6. pyrkin_vanya 342 29.06.18 20:11 Сейчас в теме
(2)В моей базе одни физики)))
3. dachnik 101 16.05.18 18:03 Сейчас в теме
Событием перед записью элемента справочника
Ссыль = Справочники.Контрагенты.НайтиПоРеквизиту("ТелНомер", Значение);
если ЗначениеЗаполнено(Ссыль) тогда Отказ=истина КонецЕсли;
Свойство, содержащее номер телефона должно быть индексируемым.
Если Номер телефона в ригистре контактнаяинформация, то ищем по номеру телефона в регистре, можно запросом, если находим, проверяем, не связан ли контакт с текущим объектом, если не связан Отказ=истина.
4. Trancer64 17.05.18 15:29 Сейчас в теме
Имхо, гораздо лучшим решением было бы выполнять указанные преобразования при записи телефонов в базу, тогда и искать потом можно обычным равенством.
5. ЧерныйКот 17.05.18 15:59 Сейчас в теме
Бред.
Во первых производить какие то преобразования номера перед поиском, во вторых оптимальность поиска под вопросом, и в третьих сам алгоритм косячный.

Вопрос к автору : А что будет с номерами вида "+7 911 111 11 11" и "8 911 111 11 11"?, "8 812 454 78 64 доб. 123" ? или с номером вида "8 911 456 76 56, звонить после 20-00, бухгалтер Нюра" ?

ЗЫ, сам реализовал такой механизм для УТ11, но одной подпиской и простенькой функцией тут не обойдешься.
Оставьте свое сообщение